Email issues due to old public folder traces in Exchange 2010 server

Recently I came across a strange issue with one of our clients. The issue is as follows “When an Exchange 2010 user having a mailbox say ‘user@example.com‘ tries to send email to any other email address, he receives an error ‘The email cannot be sent since you don’t have send on behalf permission to the mailbox” .

ie, issue is reported when ‘user@example.com‘ is trying to send mail to another user having an email address ‘newuser@domain.com‘. The user is not trying to send on behalf of anyone as well.

You might think why send on behalf permission is required to just send a mail to anyone.

So, I just took access of the user’s Outlook and tried to send a test email and viewed the error being reported. To my surprise other than the mailbox in the outlook, I found two other public folders attached in Outlook. Upon checking the contents of the folders there were no data at all. Since I was curious, I checked the size of the Public Folder Database and noticed that it had only around 130 MB indicating that the company is no longer using it.

As those folders were no longer being used, I tried to close them in Outlook, but it wont let me to. Then I noticed that one of the public folder had the same email address as the user mailbox. How can that be ?? I came to know that the company made use of Public Folders before and one day they deleted all of them, leaving behind traces in the database. Once the public folders were deleted, new mailboxes were created with the same email address due to which such an issue was reported. So the only option in front of me was to delete the old public folder traces from the database.

Following are the steps performed :

  • Launched MMC
  • From Add/Remove Snap in, selected the ADSI EDIT Snap in
  • Connect and select the Configuration
  • Navigate to the Public Folder as shown in the below image

PF1

  • Right Click and select Properties
  • From the Attribute Editor, select Proxy addresses

PF2

  • You might notice following entries as shown below, based on the number of Accepted Domains you hold

PF3

  • Delete the SMTP addresses you don’t need and click OK
  • Try dis-mounting and re-mounting the Public Folder database
  • Send test emails and confirm the mail flow

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s